AnaGate Shop
AnaGate Home » Support » FAQs

Products
News
Overview
Online-Shop
Prices/Order
Support
Documentation
FAQ's
Software-Download
Firmware-Download
Changelog
Informations
About Us
Contact Us
Terms
Imprint
Find us
facebook Facebook
facebook Google+
Languages
English Deutsch

FAQs - Frequently asked questions

Here is a list of frequently asked questions.

Questions

Problem: No LAN connection

If no LAN connection is registered (the link LED next to the RJ45 socket does not light up), please check the wiring between the AnaGate I2C and the hub or switch.You need to use a crossover cable when connecting the device directly to a PC.

Please check that the AnaGate device is connected to the power supply.

Problem: No TCP/IP connection

If you cannot set up a TCP/IP connection to the AnaGate, please proceed as follows:

  1. Check for an existing LAN connection.
  2. Check if you can address the device with a ping.
    To do this, launch the MS Windows command prompt and enter the command “ping a.b.c.d” (replace a.b.c.d with the IP address of the AnaGate). If there is no response, check whether the RX LED next to the RJ45 socket lights up while executing the ping command.
    If you still cannot address the device, perform a factory reset, configure your PC using the IP address 192.168.1.253/255.255.255.0, and repeat the aforementioned procedure using the IP address 192.168.1.254.
  3. Check whether you can open a TCP connection at port 5000.
    To do this, launch the MS Windows command prompt and enter the command “telnet a.b.c.d 5000” (replace a.b.c.d with the IP address of the AnaGate). If you do not get a connection immediately, check whether a firewall or packet filter is installed between your PC and the AnaGate.

Problem: Using a firewall

When working with a firewall, the a TCP port has to be opened for communication with the AnaGate device:

  • AnaGate I2C: port 5000
  • AnaGate CAN: port 5001
  • AnaGate CAN uno: port 5001
  • AnaGate CAN duo: port 5001 and port 5101
  • AnaGate SPI: port 5002
  • AnaGate Renesas: port 5008

AnaGate I2C problem: No I2C communication

If communication with your AnaGate I2C device fails, please proceed as follows:

  1. Check that the I2C device is connected to the power supply.
  2. Check that no other devices/µC are active on the I2C bus.
  3. Ensure that the SDA and SCL circuits are provided with an adequate pull-up resistance (e.g. 4.7 kOhm) to the voltage supply (3.3 V resp. 5 V).
  4. Ensure that no other electrical components can interfere with communication on the I2C bus between the AnaGate I2C and the I2C device.
  5. Ensure that the chip-enable address of the I2C device and the software are identical.

AnaGate I2C problem: What is the sequence of the GND / SCL and SDA contacts when using an external power supply?

To avoid potential damage to the AnaGate I2C, the GND pin MUST be connected to the application board first. Only then can the SCL/SDA pins be allowed to make contact with the application board.

Problem AnaGate SPI: Connecting to a KMA200

Accessing a KMA200 of Phillips with th AnaGate SPI is easily possible via a special adaptor.

Following you wil find a guide to  program the KMA200 device.

Guidance: Connecting AnaGate SPI to KMA200 153 KB PDF
 
<

Copyright © 2004-2015 Analytica Gesellschaft für Softwareentwicklung und EDV-Beratung mbH
Switchboard: +49-721-35043-0
Facsimile: +49-721-35043-59
  Sales: +49-721-35043-50
Technical: +49-721-35043-51